Forum Użytkowników nawigacji NaviExpert

Dyskusje na temat nawigacji NaviExpert w telefonach komórkowych i nie tylko. Zapraszamy do aktywnego udziału. Wyraź Swoją opinię lub podziel się własnymi doświadczeniami Użytkownika mobilnej nawigacji NaviExpert.

Przejdź do zawartości

FAQ |Zarejestruj | Zaloguj

Kompatybilność telefonów, a nowa wersja NE

Kompatybilność telefonów, a nowa wersja NE

Postprzez HaniaK » poniedziałek, 9 sie 2010, 11:38

Drodzy Forumowicze,
każdy wie, że sprzęt elektroniczny starzeje się bardzo szybko. Ciągle musimy zmieniać komputery, telewizory, a także telefony. W ostatnich latach rozwój telefonów był szczególnie szybki. Mimo najlepszych chęci nie jesteśmy w stanie ciągle wpierać coraz to nowszą wersją aplikacji wszystkich telefonów. Musielibyśmy wtedy ograniczyć lub nawet wstrzymać rozwój NaviExperta. Wiele telefonów Nokia pozwala np. na instalację tylko programów mniejszych niż 1MB i udostępnia programom tylko 1MB pamięcią RAM. To nie pozwala na zbyt wiele. W żaden sposób nie wstrzymujemy możliwości korzystania na starszych telefonach poprzednich wersji NaviExpert, ale nie jesteśmy w stanie zapewnić działania kolejnych, nowszych wersji programu na wszystkich modelach kompatybilnych z poprzednią wersją.
Co do telefonów z dual SIM i innych telefonów niekompatybilnych z NaviExpert. Przede wszystkim jesteśmy firmą komercyjną, która musi się kierować rachunkiem ekonomicznym. Wprowadzenie i stałe utrzymywanie wersji na każdy nowy telefon, to duży koszt, który musi nam się w sensownej perspektywie zwrócić. Siłą rzeczy musimy się kierować popularnością telefonów. Dzięki dobrej współpracy z operatorami i dostawcami telefonów możemy dość dobrze monitorować popularność różnych modeli. Aktualnie ponad 220 modeli telefonów różnych marek jest kompatybilnych z systemem NaviExpert i planujący wymianę telefonu Użytkownicy nawigacji NaviExpert w czym wybierać . Niestety osoby kupujące mało popularne modele muszą się liczyć z tym, że będą miały problemy ze znalezieniem aplikacji do takiego telefon. Sama specyfikacja Javy daje niewiele. Większość problemów wynika z błędów w Javie na poszczególne telefony. Jeżeli telefon faktycznie spełnia nasze wymagania, to prawie na pewno jedna z wersji na inny telefon da się na nim zainstalować, uruchomić i używać z co najwyżej drobnymi problemami. Zachęcamy do takich testów. Jeżeli to się nie udaje, to opracowanie wersji na taki telefon będzie trudne lub nawet niemożliwe. Na wielu telefonach z Windows Mobile, z nie do końca przez nas rozumianych powodów, instalowane są bardzo ograniczone wersje Javy.
Pozdrawiamy
HaniaK
 

Re: Kompatybilność telefonów, a nowa wersja NE

Postprzez roman_tp » poniedziałek, 9 sie 2010, 19:58

za pozwoleniem.
ja rozumiem rachunek ekonomiczny NE: poniesione nakłady muszą się zwrócić. ja rozumiem wasz sentyment do JAVA.
ale się pytam:
czy w związku z rozwojem samych aparatów, że coraz więcej telefonów ma jakiś system operacyjny [bada, android, wm, symbian], czy nie lepiej wypuścić cztery wersje lub więcej [w zależności od ilości systemów], w których to właśnie w opcjach wybieramy rozdzielczość ekranu i czy chcemy korzystać z wbudowanego GPS'a czy zewnętrznego.
cały czas bazujecie na JAVA.
jak widać to inne firmy rzucają wam kłody pod nogi [nawiążę teraz do wm], a wy w takich przypadkach ratujecie się innymi programami, dzięki którym można uruchomić NE.
podam przykład:
lnowaczyk napisał(a):Polecam zainstalować wersję dla HTC Diamond, ponieważ w tej wersji rozdzielczość jest skalowalna. Program instalujemy z cab'a, jak każdy inny program na WM.
Problem ze zbyt dużą czcionką rozwiąże program, napisany przez jednego z naszych programistów. Aby go otrzymać, proszę napisać do nas maila.
W razie gdyby powtarzały się problemy z GPSem lub inne, można zainstalować Esmerteca z lutego 2009, z tego względu, że ta wersja została przez nas przetestowana. Poza tym, w późniejszych wersjach prawdopodobnie zmniejszono ilość pamięci przeznaczonej dla aplikacji.

topic24-70.html#p7298
instaluję CAB a mam JAVA - po co? nie łatwiej od razu zrobić coś pod wm?
czy instalując NE w symbianie docelowo też mam JAVA?

czcionka - kolejną aplikację mam instalować obok esmertec'a, aby uruchomić NE?
a, jeśli po udanej instalacji okaże się, że nie ma inteligentnego wygaszana ekranu? kolejna aplikacja? to zaczyna być śmieszne.

nie zamierzam instalować kilku aplikacji, które umożliwią mi korzystanie z NE. w końcu to nie jest jakiś dziwny system - test producenta telefonów, który nie wiadomo czy się przyjmie [np. bada], tylko wm.
nie sądzę, że za rok czy dwa wm zniknie z rynku.
zamiast opracowywać aplikację na kilka modeli telefonów działających pod wm, zróbcie aplikację typowo pod wm.
ściągnełem plik instalacyjny skype, który zainstalował mi na telefonie aplikacje. nie było żadnych wymagać sprzętowych [ekran, procesor]
garmina też nie szukałem tylko pod mój telefon, tylko pod wm.

myślicie o przyszłości, a tylko myślicie ciągle o pierwszym produkcie pod JAVA.
co zrobicie, jak znikną z rynku telefony nie mające systemu? nadal będziecie wypuszczać wersje NE pod JAVA?
wspominałem, zresztą nie tylko ja, że wersja z mapami offline byłaby z korzyścią dla użytkowników, ze względu na znikomy transfer danych. czy myślicie o tym?
Avatar użytkownika
roman_tp
Użytkownik NaviExpert Użytkownik NaviExpert
Użytkownik forum Użytkownik forum
 
Posty: 673
Dołączył(a): czwartek, 16 lip 2009, 13:35
Lokalizacja: Lusówko
Telefon: CAT B15


Powrót do Archiwum 2010

Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 0 gości

Obserwuj nas na Facebooku Strona gwna NaviExpert NaviExpert Newsletter Blog NaviExpert