Strona 2 z 2

Re: [WP] NE nie przelicza trasy po zjechaniu z wyznaczonej

PostNapisane: piątek, 20 mar 2015, 13:20
przez vtec_z
Na początek dane o wersjach (uwaga NOKIA 909 to to samo co Nokia Lumia 1020)
wp_ss_20150320_0002.jpg
wersja NE
wp_ss_20150320_0002.jpg (7.49 KiB) Przeglądane 6171 razy
wp_ss_20150320_0001.jpg
dane telefonu i systemu
wp_ss_20150320_0001.jpg (44.09 KiB) Przeglądane 6171 razy


Dla NE 2.1 z tą samą wersją oprogramowania tefonu problemów nie było.
Moje testy były prowadzone przy wyznaczeniu trasy z punktem pośrednim (3x) i tylko z punktem docelowym (1x). Punkty pobrane z ulubionych. Start z aktualnej pozycji (2x) i raz dla trasy ułożonej wcześniej i zapamietanej.
We wszystkich przypadkach efekt ten sam tj. brak komunikatu o zjechaniu z trasy i brak przeliczania.

Re: [WP] NE nie przelicza trasy po zjechaniu z wyznaczonej

PostNapisane: piątek, 20 mar 2015, 17:27
przez pawel.mu
Lukasz NE napisał(a):Sprawdźcie proszę scenariusz kiedy wyszukujecie punkt z wyszukiwarki i do niego nawigujecie - czy problem się odtworzy. My szukamy przyczyn u nas, ale na razie nie udało nam się tego efektu odtworzyć.


Problem pojawia się tak przy punkcie wyszukanym, jak i wybranym z wcześniej zapisanych.
Nie miałem natomiast okazji sprawdzić jak program zachowa się, gdy zjedzie się z wytyczonej trasy, a potem na nią wróci.

Dodam jeszcze, że po niewykonaniu ostatniego manewru wskazanego przez nawigację (czyli zjechaniu z trasy) nadal wyświetlane są wskazówki na jego temat, tj. strzałka kierunku skrętu i odległość do manewru (i już się nie zmienia).

Re: [WP] NE nie przelicza trasy po zjechaniu z wyznaczonej

PostNapisane: piątek, 20 mar 2015, 21:15
przez Wilk108
Lukasz NE napisał(a):Problem zapewne występuje w jednym przypadku użycia, dlatego opiszcie co robicie po kolei, co bardzo nam pomoże wyeliminować tego buga.

Ja wybierałem trasę do zdefiniowanego wcześniej punktu (moje miejsca) albo wpisywałem adres w pole wyszukiwania "dokąd chcesz jechać". I przy obu sposobach wyboru trasy efekt występował. Program miał takie rozdwojenie jaźni: na mapie pokazywał poprawnie położenie ale na panelu informacyjnym pozostawała informacja z punktu w którym zjechałem z trasy:
zgubiona trasa.JPG
zgubiona trasa.JPG (65.49 KiB) Przeglądane 6122 razy


Po powrocie na trasę nawigacja jest dalej poprawna.